import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:[a-z0-9]*[a-z]))(?=(?:[a-z0-9]*[0-9]){3})[a-z0-9]{10,}$";
final String string = "X6JV2YUW8T\n"
+ "JN1H86LEKA\n"
+ "111JEJE134\n"
+ "A111111111\n"
+ "ABCDEFGHIJ\n"
+ "0123456789\n\n\n"
+ "X6JV2YUW8T => True\n"
+ "JN1H86LEKA => True\n"
+ "111JEJE134 => True\n"
+ "A111111111 => True\n"
+ "ABCDEFGHIJ => False\n"
+ "0123456789 => False";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}