re = /^(?=(?:[a-z0-9]*[a-z]))(?=(?:[a-z0-9]*[0-9]){3})[a-z0-9]{10,}$/mi
str = 'X6JV2YUW8T
JN1H86LEKA
111JEJE134
A111111111
ABCDEFGHIJ
0123456789
X6JV2YUW8T => True
JN1H86LEKA => True
111JEJE134 => True
A111111111 => True
ABCDEFGHIJ => False
0123456789 => False'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end