#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)g(?:o|0|<>|\[]){2}g[li][e3]"
Local $sString = "google" & @CRLF & _
"g00gle" & @CRLF & _
"g0oGle" & @CRLF & _
"g<>0gl3" & @CRLF & _
"googl3" & @CRLF & _
"GooGIe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")