$re = '/g(?:o|0|<>|\[]){2}g[li][e3]/mi';
$str = 'google
g00gle
g0oGle
g<>0gl3
googl3
GooGIe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);