using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"g(?:o|0|<>|\[]){2}g[li][e3]";
string input = @"google
g00gle
g0oGle
g<>0gl3
googl3
GooGIe";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}