package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)g(?:o|0|<>|\[]){2}g[li][e3]`)
var str = `google
g00gle
g0oGle
g<>0gl3
googl3
GooGIe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}