import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s-i)\\A(?!.*\\bCopyright MyCompany Ltd. All Rights Reserved\\b).+";
final String string = "// Just add a typo to the copyright text below for the regex to pick it up.\n"
+ "// Visual Studio uses .NET regex.\n"
+ "/********************************************************\n"
+ "* Copyright MyCompany Ltd. All Rights Reserved *\n"
+ "*********************************************************/\n"
+ "#pragma once\n\n"
+ "insert code here";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}