const regex = new RegExp('(?s-i)\\A(?!.*\\bCopyright MyCompany Ltd. All Rights Reserved\\b).+', 'gm')
const str = `// Just add a typo to the copyright text below for the regex to pick it up.
// Visual Studio uses .NET regex.
/********************************************************
* Copyright MyCompany Ltd. All Rights Reserved *
*********************************************************/
#pragma once
insert code here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}