$re = '/(?s-i)\A(?!.*\bCopyright MyCompany Ltd. All Rights Reserved\b).+/m';
$str = '// Just add a typo to the copyright text below for the regex to pick it up.
// Visual Studio uses .NET regex.
/********************************************************
* Copyright MyCompany Ltd. All Rights Reserved *
*********************************************************/
#pragma once
insert code here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);