re = /(?s-i)\A(?!.*\bCopyright MyCompany Ltd. All Rights Reserved\b).+/m
str = '// Just add a typo to the copyright text below for the regex to pick it up.
// Visual Studio uses .NET regex.
/********************************************************
* Copyright MyCompany Ltd. All Rights Reserved *
*********************************************************/
#pragma once
insert code here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end