import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ +\\w+([A-Z][a-z]+) += +(?>\\1$(*SKIP)(*FAIL)|\\w)+$";
final String string = "\n"
+ " aaaBbb = CccBbb\n"
+ " aaaDddd = CccDddd\n"
+ " aaaEeee = CccFfff\n\n"
+ " aaaDddd = CccDdddd\n\n\n"
+ "2 matches found...\n"
+ "But I want to match the 3rd line without matching the first 2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}