$re = '/^ +\w+([A-Z][a-z]+) += +(?>\1$(*SKIP)(*FAIL)|\w)+$/m';
$str = '
aaaBbb = CccBbb
aaaDddd = CccDddd
aaaEeee = CccFfff
aaaDddd = CccDdddd
2 matches found...
But I want to match the 3rd line without matching the first 2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);