const regex = /^ +\w+([A-Z][a-z]+) += +(?>\1$(*SKIP)(*FAIL)|\w)+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ +\\w+([A-Z][a-z]+) += +(?>\\1$(*SKIP)(*FAIL)|\\w)+$', 'mg')
const str = `
aaaBbb = CccBbb
aaaDddd = CccDddd
aaaEeee = CccFfff
aaaDddd = CccDdddd
2 matches found...
But I want to match the 3rd line without matching the first 2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}