import re
regex = re.compile(r"^ +\w+([A-Z][a-z]+) += +(?>\1$(*SKIP)(*FAIL)|\w)+$", flags=re.MULTILINE)
test_str = ("\n"
" aaaBbb = CccBbb\n"
" aaaDddd = CccDddd\n"
" aaaEeee = CccFfff\n\n"
" aaaDddd = CccDdddd\n\n\n"
"2 matches found...\n"
"But I want to match the 3rd line without matching the first 2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")