use strict;
my $str = '2019-09-22
2020-08-22
2020-09-21
2020-09-22
2020-09-23
2020-10-22
2021-09-22';
my $regex = qr/([3-9][0-9]{3}|2[1-9][0-9]{2}|20[3-9][0-9]|202[1-9])-[0-9]{2}-[0-9]{2}|2020-1[0-9]-[0-9]{2}|2020-09-2[2-9]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}