import Foundation
let pattern = #"([3-9][0-9]{3}|2[1-9][0-9]{2}|20[3-9][0-9]|202[1-9])-[0-9]{2}-[0-9]{2}|2020-1[0-9]-[0-9]{2}|2020-09-2[2-9]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2019-09-22
2020-08-22
2020-09-21
2020-09-22
2020-09-23
2020-10-22
2021-09-22
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)