re = /([3-9][0-9]{3}|2[1-9][0-9]{2}|20[3-9][0-9]|202[1-9])-[0-9]{2}-[0-9]{2}|2020-1[0-9]-[0-9]{2}|2020-09-2[2-9]/m
str = '2019-09-22
2020-08-22
2020-09-21
2020-09-22
2020-09-23
2020-10-22
2021-09-22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end