const regex = /(?<= t\(\')(.*?[^\\])(?=\')/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<= t\\(\\\')(.*?[^\\\\])(?=\\\')', 'gm')
const str = `<?= t('New due-date: %s for the task "%s". Are you sure?', \$task['confirm_pushed_date_due'], \$task['title']) ?>
<h2><?= t('Push the task\\'s due-date') ?></h2>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}