re = /(?<= t\(\')(.*?[^\\])(?=\')/m
str = '<?= t(\'New due-date: %s for the task "%s". Are you sure?\', $task[\'confirm_pushed_date_due\'], $task[\'title\']) ?>
<h2><?= t(\'Push the task\\\'s due-date\') ?></h2>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end