$re = '/(?<= t\(\')(.*?[^\\\\])(?=\')/m';
$str = '<?= t(\'New due-date: %s for the task "%s". Are you sure?\', $task[\'confirm_pushed_date_due\'], $task[\'title\']) ?>
<h2><?= t(\'Push the task\\\'s due-date\') ?></h2>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);