use strict;
my $str = '<?= t(\'New due-date: %s for the task "%s". Are you sure?\', $task[\'confirm_pushed_date_due\'], $task[\'title\']) ?>
<h2><?= t(\'Push the task\\\'s due-date\') ?></h2>';
my $regex = qr/(?<= t\(\')(.*?[^\\])(?=\')/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}