using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\(\d+\)|\d+(?:\s*-\s*\d+)?)(?:\s+(?:\(\d+\)|\d+(?:\s*-\s*\d+)?))*$";
string input = @"Modernization and improvement (note 9) 260 (180) 640 - 155
Modernization and improvement (note 9) 155
Modernization and improvement (note 9) 260 (180)
Modernization and improvement (note 9) 640 - 155";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}