package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\(\d+\)|\d+(?:\s*-\s*\d+)?)(?:\s+(?:\(\d+\)|\d+(?:\s*-\s*\d+)?))*$`)
var str = `Modernization and improvement (note 9) 260 (180) 640 - 155
Modernization and improvement (note 9) 155
Modernization and improvement (note 9) 260 (180)
Modernization and improvement (note 9) 640 - 155`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}