const regex = /(?:\(\d+\)|\d+(?:\s*-\s*\d+)?)(?:\s+(?:\(\d+\)|\d+(?:\s*-\s*\d+)?))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\(\\d+\\)|\\d+(?:\\s*-\\s*\\d+)?)(?:\\s+(?:\\(\\d+\\)|\\d+(?:\\s*-\\s*\\d+)?))*$', 'gm')
const str = `Modernization and improvement (note 9) 260 (180) 640 - 155
Modernization and improvement (note 9) 155
Modernization and improvement (note 9) 260 (180)
Modernization and improvement (note 9) 640 - 155`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}