// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\(\d+\)|\d+(?:\s*-\s*\d+)?)(?:\s+(?:\(\d+\)|\d+(?:\s*-\s*\d+)?))*$").unwrap();
let string = "Modernization and improvement (note 9) 260 (180) 640 - 155
Modernization and improvement (note 9) 155
Modernization and improvement (note 9) 260 (180)
Modernization and improvement (note 9) 640 - 155";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}