package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),?Pop,?`)
var str = `Pop
Pop,R'n'B,Classic Rock
Dance,Pop,R'n'B,Classic Rock
Dance,R'n'B,Pop`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}