import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",?Pop,?";
final String string = "Pop\n"
+ "Pop,R'n'B,Classic Rock\n"
+ "Dance,Pop,R'n'B,Classic Rock\n"
+ "Dance,R'n'B,Pop";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}