$re = '/,?Pop,?/m';
$str = 'Pop
Pop,R\'n\'B,Classic Rock
Dance,Pop,R\'n\'B,Classic Rock
Dance,R\'n\'B,Pop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);