re = /,?Pop,?/m
str = 'Pop
Pop,R\'n\'B,Classic Rock
Dance,Pop,R\'n\'B,Classic Rock
Dance,R\'n\'B,Pop'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end