package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)subcategory\.html\?id=([^&]*)(?:.*&)?(?:title=([^&\n]*))?`)
var str = `http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&title=BabySale
http://example.com/xyz/subcategory.html?id=3000080293&title=MegaSale
http://example.com/xyz/subcategory.html?id=3000080294&backTitle=Back&`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}