import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "subcategory\\.html\\?id=([^&]*)(?:.*&)?(?:title=([^&\\n]*))?";
final String string = "http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&title=BabySale\n\n"
+ "http://example.com/xyz/subcategory.html?id=3000080293&title=MegaSale\n\n\n"
+ "http://example.com/xyz/subcategory.html?id=3000080294&backTitle=Back&";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}