const regex = /subcategory\.html\?id=([^&]*)(?:.*&)?(?:title=([^&\n]*))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('subcategory\\.html\\?id=([^&]*)(?:.*&)?(?:title=([^&\\n]*))?', 'gm')
const str = `http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&title=BabySale
http://example.com/xyz/subcategory.html?id=3000080293&title=MegaSale
http://example.com/xyz/subcategory.html?id=3000080294&backTitle=Back&`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}