re = /subcategory\.html\?id=([^&]*)(?:.*&)?(?:title=([^&\n]*))?/m
str = 'http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&title=BabySale
http://example.com/xyz/subcategory.html?id=3000080293&title=MegaSale
http://example.com/xyz/subcategory.html?id=3000080294&backTitle=Back&'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end