using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[(?<desc>.*?)\]\].*?\[\[(?<something>.*?)\]\].*?\[\[(?<firstnumber>.*?)\]\].*?\[\[(?<secondnumber>.*?)\]\].*?\[\[(?<percentage>.*?)\]\].*?\[\[(?<value>.*?)\]\]";
string input = @"[[Description (2 words)]] - SKU: [[QREE13]] [[450]] [[7.22]] [[20%]] [[£3,249 .00]]
[[Descrition (4 words)]] SKU: [[01TDA]] [[50]] [[52.92]] [[20%]] [[£2,646.00]]
[[Description (3 words)]] SKU: [[DASQ12]] [[250]] [[21.57]] [[20%]] [[£5,392.50]] ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}