const regex = /\[\[(?<desc>.*?)\]\].*?\[\[(?<something>.*?)\]\].*?\[\[(?<firstnumber>.*?)\]\].*?\[\[(?<secondnumber>.*?)\]\].*?\[\[(?<percentage>.*?)\]\].*?\[\[(?<value>.*?)\]\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[(?<desc>.*?)\\]\\].*?\\[\\[(?<something>.*?)\\]\\].*?\\[\\[(?<firstnumber>.*?)\\]\\].*?\\[\\[(?<secondnumber>.*?)\\]\\].*?\\[\\[(?<percentage>.*?)\\]\\].*?\\[\\[(?<value>.*?)\\]\\]', 'gm')
const str = `[[Description (2 words)]] - SKU: [[QREE13]] [[450]] [[7.22]] [[20%]] [[£3,249 .00]]
[[Descrition (4 words)]] SKU: [[01TDA]] [[50]] [[52.92]] [[20%]] [[£2,646.00]]
[[Description (3 words)]] SKU: [[DASQ12]] [[250]] [[21.57]] [[20%]] [[£5,392.50]] `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}