// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\[(?<desc>.*?)\]\].*?\[\[(?<something>.*?)\]\].*?\[\[(?<firstnumber>.*?)\]\].*?\[\[(?<secondnumber>.*?)\]\].*?\[\[(?<percentage>.*?)\]\].*?\[\[(?<value>.*?)\]\]").unwrap();
let string = "[[Description (2 words)]] - SKU: [[QREE13]] [[450]] [[7.22]] [[20%]] [[£3,249 .00]]
[[Descrition (4 words)]] SKU: [[01TDA]] [[50]] [[52.92]] [[20%]] [[£2,646.00]]
[[Description (3 words)]] SKU: [[DASQ12]] [[250]] [[21.57]] [[20%]] [[£5,392.50]] ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}