import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[(?<desc>.*?)\\]\\].*?\\[\\[(?<something>.*?)\\]\\].*?\\[\\[(?<firstnumber>.*?)\\]\\].*?\\[\\[(?<secondnumber>.*?)\\]\\].*?\\[\\[(?<percentage>.*?)\\]\\].*?\\[\\[(?<value>.*?)\\]\\]";
final String string = "[[Description (2 words)]] - SKU: [[QREE13]] [[450]] [[7.22]] [[20%]] [[£3,249 .00]]\n"
+ "[[Descrition (4 words)]] SKU: [[01TDA]] [[50]] [[52.92]] [[20%]] [[£2,646.00]]\n"
+ "[[Description (3 words)]] SKU: [[DASQ12]] [[250]] [[21.57]] [[20%]] [[£5,392.50]] ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}