#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Za-z]1[A-Za-z]*1"
Local $sString = "a1bcdea1ABCa1DEFa1" & @CRLF & _
"" & @CRLF & _
"C1abdrFECsarR1C1abdrFECsarR1" & @CRLF & _
"" & @CRLF & _
"r1uaysdhahsaz1r1uaysdhahsaz1r1uaysdhahsaz1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")