// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Za-z]1[A-Za-z]*1").unwrap();
let string = "a1bcdea1ABCa1DEFa1
C1abdrFECsarR1C1abdrFECsarR1
r1uaysdhahsaz1r1uaysdhahsaz1r1uaysdhahsaz1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}