import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z]1[A-Za-z]*1";
final String string = "a1bcdea1ABCa1DEFa1\n\n"
+ "C1abdrFECsarR1C1abdrFECsarR1\n\n"
+ "r1uaysdhahsaz1r1uaysdhahsaz1r1uaysdhahsaz1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}