package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z]1[A-Za-z]*1`)
var str = `a1bcdea1ABCa1DEFa1
C1abdrFECsarR1C1abdrFECsarR1
r1uaysdhahsaz1r1uaysdhahsaz1r1uaysdhahsaz1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}