using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?!Mobile)[A-Z0-9a-z+-]){7,36}";
string input = @"SAR-+96599853915-63aa6d10-2-2Mobile
63AA6CBDMobile
<CSError>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}