$re = '/(?:(?!Mobile)[A-Z0-9a-z+-]){7,36}/m';
$str = 'SAR-+96599853915-63aa6d10-2-2Mobile
63AA6CBDMobile
<CSError>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);