use strict;
my $str = 'SAR-+96599853915-63aa6d10-2-2Mobile
63AA6CBDMobile
<CSError>';
my $regex = qr/(?:(?!Mobile)[A-Z0-9a-z+-]){7,36}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}