re = /(?:(?!Mobile)[A-Z0-9a-z+-]){7,36}/m
str = 'SAR-+96599853915-63aa6d10-2-2Mobile
63AA6CBDMobile
<CSError>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end