#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\'([^\'\\\n]|\\[abfnrtv0\\\'\"\?]|\\[0-3][0-7]{2}|\\x[0-9a-fA-F]{2})\'"
Local $sString = "'c'" & @CRLF & _
"'@'" & @CRLF & _
"'/'" & @CRLF & _
"'.'" & @CRLF & _
"'?'" & @CRLF & _
"' '" & @CRLF & _
"'n'" & @CRLF & _
"" & @CRLF & _
"'\a'" & @CRLF & _
"'\b'" & @CRLF & _
"'\f'" & @CRLF & _
"'\n'" & @CRLF & _
"'\r'" & @CRLF & _
"'\t'" & @CRLF & _
"'\v'" & @CRLF & _
"'\\'" & @CRLF & _
"'\''" & @CRLF & _
"'\"'" & @CRLF & _
"'\?'" & @CRLF & _
"'\0'" & @CRLF & _
"" & @CRLF & _
"'\000'" & @CRLF & _
"'\077'" & @CRLF & _
"'\377'" & @CRLF & _
"'\x00'" & @CRLF & _
"'\x0f'" & @CRLF & _
"'\xff'" & @CRLF & _
"" & @CRLF & _
"'a' 'a'" & @CRLF & _
"" & @CRLF & _
"// Not matched" & @CRLF & _
"'''" & @CRLF & _
"'\'" & @CRLF & _
"'\" & @CRLF & _
"'as'" & @CRLF & _
"'" & @CRLF & _
"' a'" & @CRLF & _
"'\089'" & @CRLF & _
"'\777'" & @CRLF & _
"'\477'" & @CRLF & _
"'\xga'"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")