# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\'([^\'\\\n]|\\[abfnrtv0\\\'\"\?]|\\[0-3][0-7]{2}|\\x[0-9a-fA-F]{2})\'"
test_str = ("'c'\n"
"'@'\n"
"'/'\n"
"'.'\n"
"'?'\n"
"' '\n"
"'n'\n\n"
"'\\a'\n"
"'\\b'\n"
"'\\f'\n"
"'\\n'\n"
"'\\r'\n"
"'\\t'\n"
"'\\v'\n"
"'\\\\'\n"
"'\\''\n"
"'\\\"'\n"
"'\\?'\n"
"'\\0'\n\n"
"'\\000'\n"
"'\\077'\n"
"'\\377'\n"
"'\\x00'\n"
"'\\x0f'\n"
"'\\xff'\n\n"
"'a' 'a'\n\n"
"// Not matched\n"
"'''\n"
"'\\'\n"
"'\\\n"
"'as'\n"
"'\n"
"' a'\n"
"'\\089'\n"
"'\\777'\n"
"'\\477'\n"
"'\\xga'")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.