use strict;
my $str = '\'c\'
\'@\'
\'/\'
\'.\'
\'?\'
\' \'
\'n\'
\'\\a\'
\'\\b\'
\'\\f\'
\'\\n\'
\'\\r\'
\'\\t\'
\'\\v\'
\'\\\\\'
\'\\\'\'
\'\\"\'
\'\\?\'
\'\\0\'
\'\\000\'
\'\\077\'
\'\\377\'
\'\\x00\'
\'\\x0f\'
\'\\xff\'
\'a\' \'a\'
// Not matched
\'\'\'
\'\\\'
\'\\
\'as\'
\'
\' a\'
\'\\089\'
\'\\777\'
\'\\477\'
\'\\xga\'';
my $regex = qr/\'([^\'\\\n]|\\[abfnrtv0\\\'\"\?]|\\[0-3][0-7]{2}|\\x[0-9a-fA-F]{2})\'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}