const regex = new RegExp('\\\\'([^\\\\'\\\\\\n]|\\\\[abfnrtv0\\\\\\\\'\\"\\?]|\\\\[0-3][0-7]{2}|\\\\x[0-9a-fA-F]{2})\\\\'', 'gm')
const str = `'c'
'@'
'/'
'.'
'?'
' '
'n'
'\\a'
'\\b'
'\\f'
'\\n'
'\\r'
'\\t'
'\\v'
'\\\\'
'\\''
'\\"'
'\\?'
'\\0'
'\\000'
'\\077'
'\\377'
'\\x00'
'\\x0f'
'\\xff'
'a' 'a'
// Not matched
'''
'\\'
'\\
'as'
'
' a'
'\\089'
'\\777'
'\\477'
'\\xga'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}