const regex = new RegExp('(?i)lines?(?:\\s+items?)?\\s*\\d+(?:\\.\\d+)?(?:\\s*(?:,|and)\\s*\\d+(?:\\.\\d+)?)*', 'gm')
const str = `Line 145
Line3544354
Lines 10,12
Line items 45,10,26
Lines 10 and 45
Lines 10.5666,12.566
Line 96.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}